What's new

Horn Works - No Turn Signals, Power Locks, Odometer, Rev Meter

Joined
25 December 2021
Messages
4
Reaction score
0
Points
1
Location
United States
I’ve recently replaced the battery and alternator. Car starts but the turn signals don’t work. Noticed my remote key wouldn’t unlock the doors. Main headlights turn-on but the turn signals don’t work. No hazards, no interior accessories. Some lights on the AC controls are faded. Horn does work! I’ve checked all the fuses in the interior under the steering wheel all seem to light up with test light. Also checked the fuses under the hood, all seem to be in good shape. My last suspensions are somewhere in the wire harness on the RT side fender area, unless somehow my BCM Was fried 😔
 

Joeh

Staff member
Moderator
Joined
12 December 2006
Messages
761
Reaction score
61
Points
28
Location
London
Website
www.silivaoc.com
Country
Instagram
@silviaownersclub
That's very strange

Are there any panels on the dash that have the buttons unplugged?

For example, I know if my hazard warning light button was unplugged in a another car I own, the indicators wouldn't work
 
Joined
25 December 2021
Messages
4
Reaction score
0
Points
1
Location
United States
Very strange- Hazard lights are plugged in but no function. Never had issues prior to the day it no longer started due to a failed alternator. I suspected a blown fuse but cannot seem to trace the issue.
 

Joeh

Staff member
Moderator
Joined
12 December 2006
Messages
761
Reaction score
61
Points
28
Location
London
Website
www.silivaoc.com
Country
Instagram
@silviaownersclub
Try disconnect the battery and leave it off for a few min and then reconnect?

By any chance did you accidentally touch the positive and negative together at some point?
 
Joined
25 December 2021
Messages
4
Reaction score
0
Points
1
Location
United States
Car is lowered but harness was relocated about the apron prior to this issue. So its seems like it on the cluster. (no odometer ,rpm revs, gas levels, hazard lights) the rear lights aluminate with my head lights. Although the turn signals and "brake light" doesn't seem to respond. Car runs and drives great it seems to be a ground issue or maybe a fuse I may be over looking.
 
Top