What's new

HELP!! Crazy electrical problem...

LuPix_S15

Banned Toyota Lover
Joined
14 April 2007
Messages
3,891
Reaction score
0
Points
0
Location
Shropshire, UK
Website
www.lupix.co.uk
Country
Ok folks,

Got a weird electrical issue which started halfway through DWYB last Wednesday. First, the airbag warning light started flashing on and off all the time. I assumed it was just the cancellation attachment had come loose during drifting so waited until I got home to take the aftermarket steering wheel off and put clip back on right. But after taking the cancellation clip out and putting it back in and taping it all up secure, the warning light is still flashing on and off all the time :mad:

This morning the following started happening:

1. Used Clifford remote alarm keyfob button to unlock the car as normal. Keyfob deffo working as the light is flashing ok. Usually I can hear the car door mechanism unlock and the hazards flash but there was no hazard flash. Kept trying and the hazards which flash when locking/unlocking is just not coming on at all.

2. Put the hazard lights on using main red button - it just makes a loud buzzing noise coming from somewhere behind the steering column. No hazard lights flash - basically the hazards are fooked!! However using the indicator right/left stalk turns on the same lights ok?!

3. Remote keyfob does not seem to lock/unlock the car properly anymore. I can sometimes barely hear the locking motor whirr just a little but it's not 100% doing the job.

4. However, using the manual button to lock/unlock the car on both sides from inside works absolutely fine.

Just wanted some advice on what the hell is wrong before I take it to local electrical place cos if I can fix this, rather do it myself!!

Cheers,

J
 

sniffy

Joined
27 February 2007
Messages
329
Reaction score
2
Points
18
Location
Co.Wicklow Ireland
Country
try resetting the airbag systems i had the same problem and this sorted it.

Here's the process to reset the air bag light.

Open driver door
Get in
Shut door
Turn ignition to the on position (all the way, but not to start car)
Open door
Reach down with your left hand
Press the door ajar sensor button thing (7) times
Shut door
Start your car.....
This should reset the airbag lamp.
 

LuPix_S15

Banned Toyota Lover
Joined
14 April 2007
Messages
3,891
Reaction score
0
Points
0
Location
Shropshire, UK
Website
www.lupix.co.uk
Country
Cheers mate - did this sequence twice and it worked!!

Everything's sorted now :D

Had to take it to local auto electrical place to sort the hazard button and central locking/alarm issues.
 
Joined
22 July 2010
Messages
528
Reaction score
0
Points
0
Location
Backwards in a hedge near Oxford
Country
My airbag light is flashing. I had a go at doing the above but doesnt seem to work. Am i right when i say the AJAR sensor is the rubber button to tell you weather the passenger door is open?
 

meddler

It's not easy being a green text speak nazi
Staff member
Moderator
Joined
17 October 2007
Messages
3,089
Reaction score
0
Points
36
Location
Australia
Country
yes, but you do it to your drivers door.
 
Joined
24 November 2016
Messages
16
Reaction score
0
Points
0
Age
28
Location
Roscommon, Ireland
Country
Sorry for bumping an ancient thread but I'm having the same issue with the airbag light and can't get it to go off at all, are there any other tips?
Cheers
 
Last edited:
Top