What's new

S15 Passengers Mirror - Motor

Joeh

Staff member
Moderator
Joined
12 December 2006
Messages
763
Reaction score
63
Points
28
Location
London
Website
www.silivaoc.com
Country
Instagram
@silviaownersclub
Hi all
Sorry for bombarding with my issues :( My passengers electric mirror is not functioning - does it run under a fuse or anything?

I've tried the mirror from the drivers side on the passengers side and that doesn't work either - I've tried the passengers mirror on the drivers side and it works fine.

I'm guessing its wiring otherwise its a fuse - I've cleaned all contacts and looked for any cuts but I didn't find anything :(

Any suggestions are greatly appreciated

Many thanks
Joeh
 

craig8585

I'm so cool, I have my own fan thread :p
🔥 Contributing Member 🔥
Joined
16 November 2007
Messages
4,118
Reaction score
0
Points
0
Location
Lichfield, UK
Country
Do you mean the folding part or glass-moving part? Have you used a multimeter to check if theres power getting to it?

There's a fuse box diagram in the useful links too.
 

Joeh

Staff member
Moderator
Joined
12 December 2006
Messages
763
Reaction score
63
Points
28
Location
London
Website
www.silivaoc.com
Country
Instagram
@silviaownersclub
Hi Craig (? sorry for the guessing d: )
Thanks for the reply
Had a look at the fuse box link already and couldn't work anything out - pulled each fuse and still no luck :(

Its the glass moving bit - I have Ganador mirrors which don't fold automatically unfortunately :(

Thanks
Joeh
 

craig8585

I'm so cool, I have my own fan thread :p
🔥 Contributing Member 🔥
Joined
16 November 2007
Messages
4,118
Reaction score
0
Points
0
Location
Lichfield, UK
Country
Could be a vast number of things.. I'd start with the switch itself. :)
 

craig8585

I'm so cool, I have my own fan thread :p
🔥 Contributing Member 🔥
Joined
16 November 2007
Messages
4,118
Reaction score
0
Points
0
Location
Lichfield, UK
Country
Haha!! Multimeters are the.. safer.. way to go! :)
 

meddler

It's not easy being a green text speak nazi
Staff member
Moderator
Joined
17 October 2007
Messages
3,085
Reaction score
0
Points
36
Location
Australia
Country
The fuse powers both mirrors through the mirror switch on the drivers door. If one mirror works, the problem is either the motor itself, the mirror switch or the wiring. If it was me, I would look at the mirror motor first.
 

Joeh

Staff member
Moderator
Joined
12 December 2006
Messages
763
Reaction score
63
Points
28
Location
London
Website
www.silivaoc.com
Country
Instagram
@silviaownersclub
The fuse powers both mirrors through the mirror switch on the drivers door. If one mirror works, the problem is either the motor itself, the mirror switch or the wiring. If it was me, I would look at the mirror motor first.
Thanks for the reply
I tried the passengers mirror on the drivers side it works fine, I also tried the passengers harness on the drivers side it also works fine - I'm guessing its the switch or a wire has broken behind the dashboard :(

Joeh
 

meddler

It's not easy being a green text speak nazi
Staff member
Moderator
Joined
17 October 2007
Messages
3,085
Reaction score
0
Points
36
Location
Australia
Country
I would say the switch then. Do you have a multimeter to check?
 

craig8585

I'm so cool, I have my own fan thread :p
🔥 Contributing Member 🔥
Joined
16 November 2007
Messages
4,118
Reaction score
0
Points
0
Location
Lichfield, UK
Country
Wire's don't usually become damaged or break unless they have been tampered with so I'd also go with the switch :)
 
Top