What's new

weird boost? laggy

Joined
22 May 2012
Messages
248
Reaction score
0
Points
0
Location
Gisborne, New Zealand
Country
So my cars on 10 pound max but it only gets there at max rpm like 6500rpm, i thought full boost should be on at like 3500 and also my car is very slow and unresponsive at down low rpm but only gets going at high rpm. is this normal or is there something not right?
 
Joined
21 July 2011
Messages
500
Reaction score
0
Points
0
Location
England
Country
Mine does this buddy people keep saying its a leak. Iv just put a boost controller on an all I can hit is .57 bar untill over 6k
 

S15_SAM

NisSam
Joined
21 February 2011
Messages
1,915
Reaction score
0
Points
0
Location
Chippenham, wiltshire
Country
That's not right. Even with stock boost solenoid it will be .4/5 bar until about 3.5k rpm then it should be .7bar, then at 6k rpm it will tail off alittle
 
Joined
24 November 2009
Messages
1,121
Reaction score
0
Points
0
Location
North Yorkshire
Country
As said, boost leak would be your top bet. I had a cracked intercooler pipe on the standard WMIC that took FOREVER to find, and was stopping me boosting about 0.5 bar, and causing over fuelling, rough idle, backfires.. etc.

Check ALL your air lines. From the big metal ones, check the flanges are in one piece and all the bolts all in place, and check all silicone/rubber lines to make sre they aren't worn/loose. There is no need to overtighten everything as you'll only break something. 1 bar isnt a lot of pressure at all in general terms, so an air seal should be easy to make. :)
 
Joined
9 September 2009
Messages
1,864
Reaction score
0
Points
0
Location
New Zealand
Country
Faber:
Looking at a photo of your engine bay, you could change a few things. Your intercooler & hotpipe is way too large for T28 running low boost levels, but dont change the intercooler, if you look at the size intercooler a EVO runs at a million psi you will understand what i mean by too large.
Buy some of that custom intercooler piping off trademe thats 50mm the cold pipe could be reduced to 63mm but at 70mm it will be OK, but definatly reduce the hot pipe size to 50mm. 63 and 70 hot pipes are for GTRs and 2Jz T304 powered things running 30psi and feeding a massive intercooler.
Also change your actuator arm length, if you have a air compressor, then GENTLY pressure the thing and adjust shaft bolt until it stays closed until your boost level.
This alone will gaurantee you will be hitting full boost by 3500.

A GOOD EBC will do a slimilar thing, one where you can adjust things like gain and responce. But altering the hardware that does the job is the best way to make your turbo respond.

Look on trademe for the intercooler piping, its $20 a section, and comes in all kinds of angles, all bits 600mm long.
 
Last edited:

CMR

Joined
22 August 2011
Messages
417
Reaction score
0
Points
0
Location
Yorkshire, UK
Country
His intercooler piping looks fine to me.

The one thing I did notice though is that in the picture showing the adjustable actuator, the arm from the angle of the picture is not set right, as the waste gate lever is at a 180 degree angle, it should be more like 200. This means the wastegate flap isn't being held shut, causing late spool.
 
Joined
22 May 2012
Messages
248
Reaction score
0
Points
0
Location
Gisborne, New Zealand
Country
wow im in a bit of a pickle haha took the actuator off and it when flinging back with heaps of tension now its too hard to get back on it has so much tension i cant move it with my hands. it looked real easy in videos i watched..
 
Joined
30 November 2007
Messages
2,152
Reaction score
0
Points
0
Location
Sunny Tweed Heads
Have you loosened the bolts on the bracket to give you some slack? It's a bit of a fiddly job doing it with the turbo fitted.
 
Joined
9 September 2009
Messages
1,864
Reaction score
0
Points
0
Location
New Zealand
Country
you will need to get your man hand out and a pair of pliers, and as my XXXX drinking mate above mentioned loosen the actuator bolts, didn't loose the circlip did you?

I just took a photo of mine for ya see the precisely calculated angle there, thats straight up 14.5 psi angle
 
Joined
22 May 2012
Messages
248
Reaction score
0
Points
0
Location
Gisborne, New Zealand
Country
so what am i looking to do extend the rod or tighten it in more so im pulling the wastegate out more. i've got it back on now but its not adjusted i had to hook up the hose to the wastegate to my air compressor haha. and yes i did lose the clip.. i didn't even realise it came off searched everywhere for it.
 
Joined
22 May 2012
Messages
248
Reaction score
0
Points
0
Location
Gisborne, New Zealand
Country
it seems to be weird i thought it should be able to reach it fully wound out but it was no where near and even winding it in and using the compressor it still doesn't reach the hook on bit
 
Joined
30 November 2007
Messages
2,152
Reaction score
0
Points
0
Location
Sunny Tweed Heads
You have to wind it in the increase the waste gate pressure, and to do that it has to be free from the turbo circliped end.
 
Joined
22 May 2012
Messages
248
Reaction score
0
Points
0
Location
Gisborne, New Zealand
Country
yea tried that wound it in a bit and was no way i could get it back on i think its as far as it can go pulling out of the wastegate hard to explain but i think turbo and stuffs different because the hook on bit where the circlip is can only go back as far as 90 degrees its weird ill take a photo of it
 
Top